Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-27393

Composer install fails on php 5.6

    XMLWordPrintable

Details

    • Bug
    • Resolution: Invalid
    • High
    • None
    • 1.7.0, 1.8.0, 1.9.0, 2.0.0
    • Platform stack
    • None
    • Php 5.6.30

    Description

      There's composer error while running composer install on php 5.6.

      Your requirements could not be resolved to an installable set of packages.

      Problem 1

      • Installation request for ocramius/package-versions 1.1.2 -> satisfiable by ocramius/package-versions[1.1.2].
      • ocramius/package-versions 1.1.2 requires php ~7.0 -> your PHP version (5.6.30) does not satisfy that requirement.
        Problem 2
      • Installation request for ocramius/proxy-manager 2.0.4 -> satisfiable by ocramius/proxy-manager[2.0.4].
      • ocramius/proxy-manager 2.0.4 requires php 7.0.0 - 7.0.5 || ^7.0.7 -> your PHP version (5.6.30) does not satisfy that requirement.
        Problem 3
      • Installation request for twig/twig v2.3.2 -> satisfiable by twig/twig[v2.3.2].
      • twig/twig v2.3.2 requires php ^7.0 -> your PHP version (5.6.30) does not satisfy that requirement.
        Problem 4
      • twig/twig v2.3.2 requires php ^7.0 -> your PHP version (5.6.30) does not satisfy that requirement.
      • twig/extensions v1.4.1 requires twig/twig ~1.20|~2.0 -> satisfiable by twig/twig[v2.3.2].
      • Installation request for twig/extensions v1.4.1 -> satisfiable by twig/extensions[v1.4.1].

      Steps to reproduce:
      1. Get fresh version of repo (I checked 1.7, 1.8, 1.9 and 2.0 branches. Bug occures on each of them)
      2. Run composer install

      Attachments

        Activity

          People

            Unassigned Unassigned
            tomasz.madeyski-obsolete@ez.no Tomasz Madeyski (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: